TF2Newbs Homepage

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
Pages: [1]
Print
Author Topic: Low FPS  (Read 3031 times)
Blue Banana
Newbs Regular
*

Karma: 9
Posts: 175


:|


« on: May 20, 2015, 05:17:51 PM »

Hi, I don't play TF2 often anymore because I'm busy and more interested in other games. I wanted to run TF2 to see if it runs alright after I got my laptop back a week ago from fixing a broken screen. My average FPS ranged around 20-30; there was one point where TF2 froze that I had to restart my laptop.

So I used this config to see if the game runs more smoothly. It does, but the average FPS is around 40-60, compared to the 132 that my laptop used to cap at about a year ago. Is there a cause to this? It seems to be either the laptop CPU or the game itself.
Logged  Jump To Top
kamo
Global Admin
1K Newb
*

Karma: 49
Posts: 1812


Get off my lawn.


« Reply #1 on: May 20, 2015, 05:49:19 PM »

First response to anything like this is:

* Have you updated video drivers?
* Have you updated DirectX?
* Have you updated sound drivers?

That would be the first line of questions.

After that:

* Do you have any new programs running in the background that you didn't last time it performed well?
* Do you multi-task or do things differently than you did last time it performed well?
Logged  Jump To Top

Blue Banana
Newbs Regular
*

Karma: 9
Posts: 175


:|


« Reply #2 on: May 21, 2015, 07:40:09 PM »

I realized that I had my power plan set to power saver. I set it back to high performance, and it runs smoothly as before, capping at 131 and running around 70-80 fps on average in open crowded areas, dipping down to 40 for just a second at the worst. My mistake.

I did update my audio and video drivers though, thanks for that.
Logged  Jump To Top
Nastradamus
UBER NEWB!
*

Karma: 6
Posts: 854


Zoom Zoom


WWW
« Reply #3 on: June 07, 2015, 12:36:36 PM »

First response to anything like this is:

* Have you updated video drivers?
* Have you updated DirectX?
* Have you updated sound drivers?

That would be the first line of questions.

After that:

* Do you have any new programs running in the background that you didn't last time it performed well?
* Do you multi-task or do things differently than you did last time it performed well?


Gotta check for Open GL :p *jk*
Logged  Jump To Top

2 in the bush... is worth ..
Pages: [1]
Print
 
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines
Mesh design by Bloc | XHTML | CSS